The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.
For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.
Input
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.
Output
For each integer in the input, output its digital root on a separate line of the output.
Sample Input
24
39
0
Sample Output
6
3
下面是我写的代码
import java.util.Scanner;
public class DigitalRoots_1013 {
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
while (sc.hasNext()) {
String str = sc.next();
if (str.equals(0))
System.exit(0);
System.out.println(root(str));
}
}
public static int root(String s) {
int res = 0;
if (s.length() == 1)
return Integer.parseInt(s);
else {
for (int i = 0; i < s.length(); i++) {
char c = s.charAt(i);
int cur=c-'0';
res += cur;
}
/**
* @author Administrator
*
* To change this generated comment edit the template variable "typecomment":
* Window>Preferences>Java>Templates.
* To enable and disable the creation of type comments go to
* Window>Preferences>Java>Code Generation.
*/
public class Main {
public static void main(String args[]) {
Scanner cin = new Scanner(new BufferedInputStream(System.in));
String s;
while(true) {
s = cin.nextLine();
if(s.equals("0"))
break;
while(s.length()>1) {
int sum = 0;
for(int i=0;i<s.length();i++) {
sum+=s.charAt(i)-48;
}
s = String.valueOf(sum);
}
System.out.println(s);
}
}
}
我对比着看,还是没看出是哪的问题,求教大神 ------解决方案-------------------- str.equals("0")
不是str.equals(0) ------解决方案--------------------