日期:2014-5-16 浏览次数:20173次

Tomcat的This release of Apache Tomcat was packaged to run on J2SE 5.0 or later问题

错误信息:

??????? This release of Apache Tomcat was packaged to run on J2SE 5.0 or later. It can be run on earlier JVMs by downloading and installing a compatibility package from the Apache Tomcat binary download page

??????——本ApacheTomcat需要在J2SE5.0或者更高的版本上运行。通过在从ApacheTomcat的二进制下载页面下载和安装兼容包它也可以运行在早期的JVM上!

??????———自己翻译的,如果有翻译的不好的地方,请留言指正.....以免让俺在学习过程中在歧途上越走越远!

?

出现此情况的原因:

?

???? Tomcat 5 使用JMX 作为管理和监控机制,但是J2SE 1.4 本身并不支持JMX ,像ObjectName 这些JMX 类 并不包括J2SE 1.4 的API 中。因此,Tomcat 5 不能直接运行 在J2SE 1.4 及之前版本上。 但是Tomcat 5 的设计目标是支持运行在J2SE 1.4 上的。因此,要达到这个目标,Tomcat 5 须 将JMX 类作为兼容包(compatibility package )额外添加到Tomcat 启动类路径中。

我们有两种方法获得兼容包:

????? 1、从Tomcat的官方下载页面下载兼容包

?????????? 参见http://tomcat.apache.org/download-55.cgi

??????2、从Tomcat 的源代码构建兼容包

?????????? 参见http://jarfield.iteye.com/blog/604198

????? 不管怎样,Tomcat5不能保证用户安装了兼容包,因此在启动时,它首先检查能够加载ObjectName类,以此判断兼容包是否安装。如果没有安装,则向标准 输出打印一条错误信息:

???????This release of Apache Tomcat was packaged to run on J2SE 5.0 or later. It can be run on earlier JVMs by downloading and installing a compatibility package from the Apache Tomcat binary download page.